Autoridad certificadora

Hoy nos escribió un usuario al correo de soporte acerca de un problema que se le está presentando con la biblioteca y quise publicar este post para que la solución pueda ser accesible para todos:

Cuando trato de crear un CFDI para un nuevo cliente del SAT (se dieron de alta el viernes pasado) me sale el siguiente mensaje e ErrorText: ‘El certificado definido para firmar no es válido contra la autoridad certificadora’

Inicialmente iba a responder a este usuario directamente, pero decidid publicar este  post porque considero que puede ser útil a todos los usuarios.

Este mensaje aparece porque el SAT cambio el certificado con el que está generando los certificados de sello, para solucionar este problema se tiene dos opciones:

1. Actualizarte a la última versión de la biblioteca
En esta última versión ya se trae contemplado este cambio que hizo el SAT y que paso desapercibido para muchos.

2. Desactivar la validación contra la autoridad certificadora
Esta es otra opción que nos permite salir rápidamente del problema pero que a la larga nos va a traer más problemas, ya que pueden estar generando comprobantes con certificados que no fueron expedidos por el SAT y por lo tanto sería apócrifos.

Nuestra recomendación es que se use la primera opción, ya que en la última versión se han corregido algunos problemas y se hecho bastantes mejores, además de que ya permite estar preparados para las nuevas versiones del comprobantes.

Así que ya saben todos a actualizarse.

Hasta la próxima.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*