Nuevas librerías-Compatibilidad con código (programación)

Librería con la que podrás llevar a cabo la validación de tus comprobantes fiscales digitales y así determinar su autenticidad y deducibilidad.
rmartinez1006
Mensajes: 4
Registrado: Mar May 02, 2017 12:27 pm

Nuevas librerías-Compatibilidad con código (programación)

Mensajepor rmartinez1006 » Mar May 02, 2017 12:40 pm

Buen día, a partir de esta nueva liberación en donde cambian las librerías, nuevas librerias (HyperSoft.ElectronicDocumentLibrary.dll y HyperSoft.Resource.dll), a pesar de que la documentación dice que "La librería es compatible con versiones anteriores, por lo tanto, deberá funcionar con tu código actual sin problemas.", al quitar las librerías anteriores y agregar estas nuevas, mi código no compila. ¿Tendrán alguna guia para realizar el cambio y/o consideraciones que debemos tener? Programación en C#.
De antemano agradezco el apoyo.

Avatar de Usuario
Facturando
Administrador del Sitio
Mensajes: 266
Registrado: Vie Oct 07, 2016 5:07 pm

Re: Nuevas librerías-Compatibilidad con código (programación)

Mensajepor Facturando » Mar May 02, 2017 1:03 pm

Hola

"La librería es compatible con versiones anteriores, por lo tanto, deberá funcionar con tu código actual sin problemas."

así es, se tomaron los ejemplos que trae la última versión, se sustituyeron los assemblies y se probó que todo funcionara correctamente.

Si tienes una version muy vieja, 2 0 3 años, podría no funcionar el código, pero esto no es nuevo, ya hasta con la version anterior te daria el mismo problema.

mi código no compila

Como desarrollador de software, comprenderás, que esta información nos es de poca utilidad, es poco lo que podemos hacer en este caso, pero si nos compartes más datos (mensaje de error, C# o VB.Net, versión de .Net Framework, versión de Visual Studio, versión de EDL que tenías anteriormente, etc; seguramente podremos darte alguna sugerencia.

Saludos

rmartinez1006
Mensajes: 4
Registrado: Mar May 02, 2017 12:27 pm

Re: Nuevas librerías-Compatibilidad con código (programación)

Mensajepor rmartinez1006 » Mar May 02, 2017 1:30 pm

Gracias... con respecto a la versión de las librerías, he ido actualizando las versiones, ya que tienen caducidad, y precisamente el día de hoy la librería ya no funcionó (caducaba en mayo) , baje las actualizaciones (como en ocasiones anteriores), las librerías anteriores eran:

HyperSoft.ElectronicDocument.Validator.dll
HyperSoft.ElectronicDocument.Validator.Remote.dll
HyperSoft.Shared.dll

Las nuevas librerías:
HyperSoft.ElectronicDocumentLibrary.dll
HyperSoft.Resource.dll

Anteriormente únicamente remplazaba las librerías (.dll) y compilaba sin problemas. Adjunto archivo .jpg con errores. Gracias.
Adjuntos
error_sat.jpg
Errores en C#
error_sat.jpg (141.58 KiB) Visto 214 veces

Avatar de Usuario
Facturando
Administrador del Sitio
Mensajes: 266
Registrado: Vie Oct 07, 2016 5:07 pm

Re: Nuevas librerías-Compatibilidad con código (programación)

Mensajepor Facturando » Mar May 02, 2017 1:38 pm

Agradecemos los datos, ahora entendemos mejor el tema.

Una pregunta, ¿esa imagen la tomaste del código de ejemplo que trae la librería o es tu código?

Si es de tu código, ¿podrías probar el ejemplo que trae la librería para ver si te compila?

Que versión de .Net usas y que versión de Visual Studio

Saludos

rmartinez1006
Mensajes: 4
Registrado: Mar May 02, 2017 12:27 pm

Re: Nuevas librerías-Compatibilidad con código (programación)

Mensajepor rmartinez1006 » Mar May 02, 2017 3:19 pm

Es código de ejemplo que traía su paquete de librerías el año pasado (aprox. mayo del 2016), conforme han ido liberando las librerías, las he actualizado sin problema, solo con esta última tengo problemas.

La versión última compila bien y funciona bien con los ejemplos de xml que trae, al presionar el botón "CFDI Versión 3.3", pero, si utilizo otro xml, me devuelve este mensaje:

"No se pudo llevar a cabo el proceso, por favor póngase en contacto con el administrador o proveedor del software y proporcionele el siguiente código: ( L1 )"

La versión de Visual Studio es la versión 2010.

Gracias.
Adjuntos
facturando.jpg
facturando.jpg (43.67 KiB) Visto 202 veces

Avatar de Usuario
Facturando
Administrador del Sitio
Mensajes: 266
Registrado: Vie Oct 07, 2016 5:07 pm

Re: Nuevas librerías-Compatibilidad con código (programación)

Mensajepor Facturando » Mar May 02, 2017 4:14 pm

rmartinez


La versión última compila bien y funciona bien con los ejemplos de xml que trae, al presionar el botón "CFDI Versión 3.3".

Creo que existe una confusión, la última imagen que nos envías es de Electronic Document Library (EDL) y tu estas preguntando por la librería de validación; son productos diferentes.

La primera imagen que publicaste es de Electronic Document Validator (EDV).

¿Cuál de los dos usas? En caso de usar los dos, ¿con cuál tienes problemas?

Por cierto, te da error L1, porque para usar esa librería (EDL) requieres una licencia.

Saludos

rmartinez1006
Mensajes: 4
Registrado: Mar May 02, 2017 12:27 pm

Re: Nuevas librerías-Compatibilidad con código (programación)

Mensajepor rmartinez1006 » Mar May 02, 2017 4:29 pm

Gracias, es cierto, me equivoque al "bajar" la libreria, la que utilizo es Electronic Document Validator (EDV).

Una disculpa,
Nuevamente gracias,
Saludos.

Avatar de Usuario
Facturando
Administrador del Sitio
Mensajes: 266
Registrado: Vie Oct 07, 2016 5:07 pm

Re: Nuevas librerías-Compatibilidad con código (programación)

Mensajepor Facturando » Mar May 09, 2017 10:48 am

De nada,

Saludos


Volver a “Electronic Document Validator”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado